Tag Archives: pdt

Eclipse Europa 3.3.2 and PHP PDT 1.0.3

Eclipse Europa 3.3.2 and PHP PDT 1.0.3

Note to avoid any of the following install errors you must use the exact versions of Eclipse and PDT specified below:

  • PDT Feature (1.0.3.v20080603-79-7PE7QYGHNH6Gh) requires feature "org.eclipse.wst (2.0.0)", or compatible.
  • PDT Feature (1.0.5.v20081126-1856) requires feature "org.eclipse.wst (3.0.0)", or compatible.
  • Eclipse XML Editors and Tools (2.0.2.v200802150100-7A1ECMCnbcl1bVs9uNm_Zkieb7Qe) requires plug-in "org.eclipse.wst.validation (1.1.0)", or equivalent.

Obtain Eclipse & PDT

  1. Download and install Java SE 6
  2. Download Eclipse Europa 3.3.2 JEE Edition
  3. Unzip Eclipse and move to /opt/eclipse or another path with no spaces in it
  4. Download Zend PDT 1.0.3 zip file
  5. Unzip PDT 1.0.3 and move to a path with no spaces in it

Run Eclipse

  1. Help | Software Updates | Find & Install
  2. Search for New Features to Install
  3. Next
  4. New Local Site
  5. Enter name of PDT and path to unzipped PDT
  6. Check PDT
  7. Install PDT

Restart Eclipse

You can now use Eclipse to write PHP projects !

Read and post comments | Send to a friend

Advertisements

Eclipse PHP PDT Project

The Eclipse PDT project provides a PHP Development Tools framework for the Eclipse platform.

PS The PHP Development Tools project has now replaced the Eclipse PHP IDE project

Read and post comments | Send to a friend